May 22, 2018 - 10:44:19 am

Serio error pone en jaque nuevamente a procesadores Intel

Cuando pensábamos que Meltdown y Spectre lo habían hecho todo por este año, acaba de aparecer un nuevo error en los procesadores que se aprovecha de la ejecución especulativa de los CPUs Intel.

Expertos de Google y Microsoft acaban de difundir el fallo denominado Speculative Store Bypass (variante 4). Se trata de una vulnerabilidad similar a Spectre, que explota la ejecución especulativa que utilizan las CPU modernas. La ejecución especulativa permite a los procesadores funcionar más rápido, puesto que se adelanta a las ejecuciones que se harán en un futuro para ganar velocidad.

Afortunadamente, la vulnerabilidad no ha pillado desprevenidos a los principales fabricantes y se incluirán actualizaciones de firmware para las CPUs implicadas. De hecho, Intel ya ha entregado actualizaciones a los OEM y estarán disponibles en las próximas semanas de forma oficial, según informa The Verge.

Pero acá viene otro problema: el rendimiento. Tal como pasó en enero, los parches nuevamente afectan la velocidad de los procesadores. Los expertos estiman que podrían disminuir hasta un 8% su eficiencia, porcentaje no menor, sobre todo en servidores o para trabajo pesado.

El error habría sido notificado por Microsoft en noviembre del año pasado a la industria, aunque no fue publicado hasta ahora. Como resultado, los usuarios finales nuevamente tendrán que elegir entre la seguridad o el rendimiento óptimo.

El siguiente video de Red Hat ilustra el problema, mencionando: “Las amenazas en las nuevas tecnologías son un desafío con el que todos debemos tratar. Por esto, es esencial mantener las líneas de comunicación abiertas, tanto entre las compañías tecnológicas, como con la comunidad y los investigadores":


Extraída de: Fayerwayer

Siguiente Más